You are not logged in.

Dear visitor, welcome to Marcels OMSI-Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

  • "Christopher SD202" started this thread

Date of registration: Dec 24th 2011

Location: Nürnberg

Occupation: Fachkraft im Fahrbetrieb

Thanks: 6

  • Send private message

1

Friday, March 9th 2012, 10:10pm

IBIS: Verfrühung/Verspätung anders anzeigen

Hallo,

kann ich die Verfrühung statt - das + (wie es in Nürnberg gemacht wird) machen? Selbes gilt bei der Verspätung vom + zum - !
Ist das mögliche?

Mfg Christopher
Grüsse aus Nürnberg!

Mfg Christopher Hecht
Vorsitzender Hecht Reisen
www.hecht-reisen.de.tl

Date of registration: Dec 3rd 2011

Location: Brandenburg an der Havel

Thanks: 2843

  • Send private message

2

Friday, March 9th 2012, 10:26pm

Dazu suchst du im Fahrzeugordner der SD202 die Datei IBIS-2.osc. Im unteren Teil des Quelltextes musst du das + gegen - und - gegen + austauschen. Fertig!
Regeln|Suchfunktion|FAQ|OMSIWiki|Das Team|Infos zum Thema Betatests|Expertenforum
Supportanfragen per PN unerwünscht! Bei Supportanfragen wendet euch bitte an die Experten.

"Der Moderator mit dem '&' im Namen."
"Tadeln ist leicht, deshalb tun es so viele. Mit Verstand loben ist schwer, deshalb tun es so wenige." (Anselm Feuerbach, dt. Maler)

  • "Christopher SD202" started this thread

Date of registration: Dec 24th 2011

Location: Nürnberg

Occupation: Fachkraft im Fahrbetrieb

Thanks: 6

  • Send private message

3

Saturday, March 10th 2012, 12:01pm

Hallo,

danke, das hat schon mal geklappt. Dann hätte ich noch eine Frage: Kann ich die Verspätung dann auch so anzeigen dass sie nur nich in halbe minuten schritte zählt (also -0,5; -1; -1,5 usw) statt alle 6 sekunden dann alle 30 sekunden, ist das mögliche?
Danke für die Antworten!

Mfg Christopher
Grüsse aus Nürnberg!

Mfg Christopher Hecht
Vorsitzender Hecht Reisen
www.hecht-reisen.de.tl

BlendWeb-OMSIDriver

Unregistered

4

Saturday, March 10th 2012, 12:16pm

Hierzu musst du in folgendem Abschnitt die rot markierte Zahl durch z.B. 30 für 30Sek. ersetzen:


'Anzeigen der aktuellen Fahrplanlage:

(L.L.elec_busbar_main)
{if}
""
(M.V.GetTTDelay) s1 60 / s0
(M.V.GetTTDelay) (S.L.omnibus_delay)

' Minuten:
l0 abs trunc " 2" $IntToStrEnh $+
(S.$.IBIS_Delay_min)

' Zehntelminuten:
l0 abs l0 abs trunc - 10 * " 1" $IntToStrEnh
(S.$.IBIS_Delay_sec)

l1 abs 6 >=
{if}
l0 0 >
{if}
"+"
{else}
"-"
{endif}
{else}
" "
{endif}
(S.$.IBIS_Delay_state)
{else}
"" (S.$.IBIS_Delay_min) (S.$.IBIS_Delay_sec) (S.$.IBIS_Delay_state)
{endif}



'Omsi sagen, dass die Strings-Ausgaben aktualisiert werden sollen:
1 (S.L.Refresh_Strings)

  • "Christopher SD202" started this thread

Date of registration: Dec 24th 2011

Location: Nürnberg

Occupation: Fachkraft im Fahrbetrieb

Thanks: 6

  • Send private message

5

Saturday, March 10th 2012, 12:28pm

Hallo,

tut mir leid das zu sagen, aber es funktioniert bei mir nicht. Der zählt weiterhin von 9-1 runter, hab es aber so gemacht wie du beschrieben hast!

Mfg Christopher
Grüsse aus Nürnberg!

Mfg Christopher Hecht
Vorsitzender Hecht Reisen
www.hecht-reisen.de.tl

Date of registration: Dec 3rd 2011

Location: Brandenburg an der Havel

Thanks: 2843

  • Send private message

6

Sunday, March 11th 2012, 4:48pm

Schau 'mal ins alte Forum. Da gibt es dieses Thema: http://omnibussimulator.forumieren.com/t…highlight=ibis2

Ansonsten vielleicht beim User "Fabi" anfragen; bei ihm scheint es zu funktionieren.
Regeln|Suchfunktion|FAQ|OMSIWiki|Das Team|Infos zum Thema Betatests|Expertenforum
Supportanfragen per PN unerwünscht! Bei Supportanfragen wendet euch bitte an die Experten.

"Der Moderator mit dem '&' im Namen."
"Tadeln ist leicht, deshalb tun es so viele. Mit Verstand loben ist schwer, deshalb tun es so wenige." (Anselm Feuerbach, dt. Maler)

Date of registration: Dec 6th 2011

Location: Wanne-Eickel

Occupation: Kutscher

Thanks: 11

  • Send private message

7

Sunday, March 11th 2012, 5:17pm

Fabi kann man aber leider nicht kontaktieren....
Dieser User ist leider zur Zeit nicht erreichbar. Für nähere Informationen Besucht sein Profil!

[Diese Signatur ist in Deutschland leider nicht verfügbar,
da sie möglicherweise Inhalte enthält, für die die erforderlichen Rechte von der
GEMA nicht eingeräumt wurden.]

Date of registration: Dec 3rd 2011

Location: Brandenburg an der Havel

Thanks: 2843

  • Send private message

8

Sunday, March 11th 2012, 6:25pm

Ach ja, stimmt! Dann muss er das mal ohne Hilfe probieren. Wenn's nicht klappen sollte, dann gib's hier hoffentlich noch andere, die das schon gemacht haben. Die könnten sich notfalls ja äußern.
Regeln|Suchfunktion|FAQ|OMSIWiki|Das Team|Infos zum Thema Betatests|Expertenforum
Supportanfragen per PN unerwünscht! Bei Supportanfragen wendet euch bitte an die Experten.

"Der Moderator mit dem '&' im Namen."
"Tadeln ist leicht, deshalb tun es so viele. Mit Verstand loben ist schwer, deshalb tun es so wenige." (Anselm Feuerbach, dt. Maler)

Date of registration: Dec 6th 2011

Location: Wanne-Eickel

Occupation: Kutscher

Thanks: 11

  • Send private message

9

Sunday, March 11th 2012, 6:32pm

Also bei mir hat es nicht funktioniert...
Dieser User ist leider zur Zeit nicht erreichbar. Für nähere Informationen Besucht sein Profil!

[Diese Signatur ist in Deutschland leider nicht verfügbar,
da sie möglicherweise Inhalte enthält, für die die erforderlichen Rechte von der
GEMA nicht eingeräumt wurden.]

Date of registration: Dec 3rd 2011

Location: Brandenburg an der Havel

Thanks: 2843

  • Send private message

10

Sunday, March 11th 2012, 6:47pm

Das ist schon schlecht. Dann kann ich auch vorerst nicht mehr helfen. Ich habe schon in anderen Foren nachgeschaut, bisher habe ich keine wirkliche Lösung gefunden.
Regeln|Suchfunktion|FAQ|OMSIWiki|Das Team|Infos zum Thema Betatests|Expertenforum
Supportanfragen per PN unerwünscht! Bei Supportanfragen wendet euch bitte an die Experten.

"Der Moderator mit dem '&' im Namen."
"Tadeln ist leicht, deshalb tun es so viele. Mit Verstand loben ist schwer, deshalb tun es so wenige." (Anselm Feuerbach, dt. Maler)

Date of registration: Dec 6th 2011

Location: Wanne-Eickel

Occupation: Kutscher

Thanks: 11

  • Send private message

11

Monday, March 12th 2012, 1:18pm

Also ich hab mit Fabi geschrieben, und er hat mir verraten was zu tun ist :D

Quoted

Suche in der IBIS2.osc folgende Zeile:
' Zehntelminuten:

ersetze dann den Code darunter zu:

l0 abs l0 abs trunc - 2 * trunc 5 * " 1" $IntToStrEnh
(S.$.IBIS_Delay_sec)

Das wars. Wenn's nicht klappt, habe ich keine Ahnung. :-)



Also bei mir hats wunderbar funktioniert...

Also auch an dieser Stelle noch mal Vielen Dank an Fabi!
Dieser User ist leider zur Zeit nicht erreichbar. Für nähere Informationen Besucht sein Profil!

[Diese Signatur ist in Deutschland leider nicht verfügbar,
da sie möglicherweise Inhalte enthält, für die die erforderlichen Rechte von der
GEMA nicht eingeräumt wurden.]

Thanks: 398

  • Send private message

12

Thursday, January 3rd 2013, 9:53pm

Also so klappt es bei mir :

du öffnest den Omsi ordner da suchst du den Vehicle ordner dann gehst du in Sd202 dann auf skript dann auf ibis2

da kopierst du dann das rein also nur das was ich hier schreibe dann ersetzen :

'Anzeigen der aktuellen Fahrplanlage:

(L.L.elec_busbar_main)
{if}
""
(M.V.GetTTDelay) s1 60 / s0

' Minuten:
l0 abs trunc " 2" $IntToStrEnh $+
(S.$.IBIS_Delay_min)

' Halbe Minuten:
l0 abs l0 abs trunc - 10 * " 1" 5 >=
{if}
"5"
{else}
" "
{endif}
(S.$.IBIS_Delay_sec)
l1 abs 60 >=
{if}
l0 0 >
{if}
"-"
{else}
"+"
{endif}
{else}
" "
{endif}
(S.$.IBIS_Delay_state)
{else}
"" (S.$.IBIS_Delay_min) (S.$.IBIS_Delay_sec) (S.$.IBIS_Delay_state)
{endif}
Bääääääääääääm.....

Date of registration: Dec 26th 2011

Thanks: 888

  • Send private message

13

Thursday, January 3rd 2013, 11:06pm

Das ist schön. Aber: Warum kramst Du für diese Information einen fast zehn Monate alten Thread raus? Vor allem, da damals ja anscheinend funktionierende Lösungen gepostet wurden. Oder ist mir da was entgangen? ?(
Regeln|Suchfunktion| FAQ| Wiki|Das Team|Infos zum Thema Betatests|Expertenforum
Supportanfragen per PN unerwünscht! Bei Supportanfragen wendet euch an die Experten.